Resolved No records found for model EnjinCoin\\EnjinOauthClient

dubalol

New member
Hello,

When trying to approve my wallet allowance I get the following error:

"message": "No records found for Model: EnjinCoin\\EnjinOauthClient",
"code": 404

My wallet daemon is running and I substituted my identity_id into the mutation script as per the documentation.

What is the problem here?
 

dubalol

New member
I switched to the mobile wallet instead of the Windows wallet. I was able to approve the Enjin allowance in the REQUESTS section of the wallet upon linking to the identity and getting the default pop-up.

However when trying to CreateEnjinRequest and request a new token, I receive the same error:

"message": "No records found for Model: EnjinCoin\\EnjinOauthClient",
"code": 404

This error doesn't return with all mutation scripts, as I AM able to create Enjin apps from GraphQL.

It seems GraphQL has trouble talking to my wallet, and it has something to do with the Oauth client. Still need help determining what this is please!
 

dubalol

New member
Hi! Are you setting your app id in the appId arg in your mutation?
That worked, thank you :)

Previously I was just setting the X-App-Id cookie in chrome dev tools to my appId as per the video tutorial. Also tried naming the cookie X-AppId and X-appId, to no avail. Not sure why none of those worked for me. But should have just looked deeper into the documentation!
 
Last edited:
Top